ERROR: code is mandatory